My G-Shock Feedback Forum » Feedback

Replaced new battery, but watch just shuts off after a few seconds


  1. i just replaced the battery with a brand new one, but my watch wont stay on. i have to push the mode button and it will come on for a few seconds and then just cut off. battery shop tested the battery and it had a lot of juice. Any ideas?? Thx

    Posted 13 years ago #
  2. Thomas

    Germany

    maybe the contact places are dirty.

    AFAIK you should use a plastic tweezers, because of your fingers can run down the battery power.

    http://mygshock.com/2008/06/21/how-to-change-a-g-shock-battery/

    Thomas

    Posted 13 years ago #
  3. Riley

    Philadelphia

    Check out Sjors' video in the link Thomas posted. There's a few things that could have gone wrong, but if you do it exactly as he shows then it should work.

    Posted 13 years ago #
  4. G-shock1968

    Illinois for now

    Sounds to me like you need to do a AC reset with a pair of metal tweezers justlike in Sjors battery tutorial video.

    Posted 13 years ago #
  5. Mine has simply quit. I've replaced the battery twice (and have done it correctly), reset the AC, but it just keeps fading out.
    It finally decided to stop altogether by constantly glowing and finally ran out of power. this occurred approximately thirty two hours after i swapped the battery a second time (and all my button contacts looked fine, weren't stuck, etc.). I've inspected it for any corrosion or deterioration, and its all clean on the inside, the gasket is in good condition with no dry-rot, cracks, splits, or tears, still has a sheen from the krytox lube i used. crappy thing is its been thirteen months, and i'm just now out of warranty. its quite dissapointing. i've an older gulfman, but i always like to have a backup, and i'm completely baffled.

    Posted 13 years ago #
  6. Riley

    Philadelphia

    deepseabeast - something definitely sounds off there. I'll see if I can find an asnwer for you. The battery will be quickly depleted with a lot of backilight use, but unless you've got a bad battery it should still last a long time.

    Posted 13 years ago #
  7. Riley

    Philadelphia

    I haven't been able to find an answer for you. You should post this in the WUS G-Shocks forum:
    http://forums.watchuseek.com/forumdisplay.php?f=17

    Those guys are great at finding answers to these types of problems.

    Posted 13 years ago #
  8. It sounds a bit odd. Is the watch reset well? Another possibility is that the battery is faulty. I buy batteries in bulk and some of a lot do not have enough power/energy. My suggestion is to take a fresh battery and do not forget the reset. If this does not work, take out the battery and leave the watch for about 24 hours. Than try again. Don't ask me why, but some stubborn modules.

    Good luck!

    Sjors

    Posted 13 years ago #
  9. Riley

    Philadelphia

    Thanks for the help Sjors. That's good advice. I hope that does the trick.

    Posted 13 years ago #
  10. So far I've tried four batteries, two rayovacs and two energizers, i've done sucessful resets several times on each. I've removed the latest energizer and i'll leave it alone without a battery for a couple days. After installing a new battery, i'll post an update. I'm still curious as to what has gone on with it.
    Thanks for the help.

    Posted 13 years ago #
  11. I've installed a new battery, correctly, reset the AC, and all seemed successful, until about an hour ago and it simply went kaput, however it was odd this time it did it, it displayed half digits and there was one that looked like an eighth note or something similar, It looked like gibberish, and I couldn't make anything out, it wasn't a test-screen that's for sure. i wish I had a camera at the time to take a picture before it faded out, now, i think its just dead. I think i'll set it aside for something to remember my diving days when i'm older, i dunno.
    I appreciate the help guys.

    Posted 13 years ago #
  12. Riley

    Philadelphia

    That sucks deepseabeast. I guess it's possible that the module was damaged somehow. I'll let you know if I hear of anything else to try.

    Posted 13 years ago #
  13. falcon4311

    Edmonton Alberta Canada

    My understanding is that Casio's C.S. is very good. I wondering if it my be best to ship the watch to them to see what a cost estimate might be. Who knows, it may be inexpensive.

    Posted 12 years ago #

Reply

You must log in to post.